Public statistics are experiencing temporary outage
Incident Report for One Click Crypto
Resolved
The incident has been resolved and the public statistics are operational again
Posted May 11, 2022 - 13:30 UTC
Investigating
We are currently investigating the root cause and working towards an immediate resolution
Posted May 11, 2022 - 12:49 UTC
This incident affected: OB Trader Application.