Service Maintenance
Incident Report for One Click Crypto
Resolved
The maintenance is over and the platform should be fully operational
Posted May 15, 2022 - 20:10 UTC
Investigating
The platform is undergoing short maintenance. Everything should be operational in a few minutes. We are sorry for the inconvenience!
Posted May 15, 2022 - 17:25 UTC
This incident affected: OB Trader Application.