Binance.US Maintenance
Incident Report for One Click Crypto
Resolved
Binance.US is operational again
Posted Feb 08, 2022 - 13:53 UTC
Identified
We are working on integration changes recently introduced by Binance.US. In the meantime, the usage of Binance.US is not advised.
Posted Feb 03, 2022 - 13:56 UTC
This incident affected: OB Trader Application.