Service Maintenance
Incident Report for One Click Crypto
Resolved
This incident has been resolved.
Posted May 19, 2022 - 23:03 UTC
Investigating
We are transitioning to our new One Button Capital domain fully. We aim for a smooth transition but there might be short interruptions. We are sorry for the inconvenience!
Posted May 19, 2022 - 09:51 UTC
This incident affected: OB Trader Application.